OCI: PDB plugin violations

This note is how to handle the common plug-in violations warning or errors found during eBS lift and shift to OCI and OCI-c.

 

#1 Database option OMW mismatch: PDB installed version NULL. CDB installed version 12.1.0.2.0

Solution: install the oracle workspace manager by running @?/rdbms/admin/owminst.plb

 

#2 Database option DV mismatch: PDB installed version NULL. CDB installed version 12.1.0.2.0

Solution: install DV on the PDB by running the script ?/rdbms/admin/catmac SYSAUX TEMP <syspassword>

 

#3 Database option OLS mismatch: PDB installed version NULL. CDB installed version 12.1.0.2.0.

Solution: Upgrade the pdb with ?/rdbms/admin/catols.sql

 

#4 Database option MGD mismatch: PDB installed version 12.1.0.2.0. CDB installed version NULL

Solution not tested, but it should be solved by applying the patch 22747454 which is part of the ETCC bundle.
Note that the datapatch portion of this patch may result into an error “ORA-25932 Error at line 68: ORA-29532: Java call terminated by uncaught Java exception” that may be solved by running the following workaround, before running again datapatch.

 call dbms_java.grant_policy_permission('JAVA_ADMIN','SYS','javax.management.MBeanServerPermission','*');
 call dbms_java.grant_policy_permission('JAVA_ADMIN','SYS','javax.management.MBeanPermission','*');

 

#5 PDB needs to import keys from source

 Solution: Import the key following this note.
Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s